FAQ für Larson2

Letzte Änderung: 08.11.2004

Ei gude. So ein Programm bedient sich net selbst. Hilfe muss wohl schon sein. Ich hab' mir das mal so gedacht: Das allergröbste hab' ich hier schon aufgeschrieben. Wenn Du Fragen oder Probleme hast, und die Antwort steht hier nicht, mich einfach per Email fragen (hilfe.larson2 ätt fractsurf punkt de). Die Antwort darauf schreib ich dann auch hier rein und stelle die Datei regelmässig auf die Homepage von Larson2. So entsteht mit der Zeit vielleicht sogar was brauchbares;-)
Vor dem Fragen aber bitte hier nachschauen, ob Deine Frage vielleicht schon beantwortet wurde :-)



Themen

Was? Woher? Wieviel? Was gibt's zum Abendessen?

Larson2 einrichten

Neuen User anlegen

Neuen Con anlegen

Rechte in Larson2

Das Geldsystem

Neuen Datensatz anlegen

Zugriff auf Datensätze: Das Suchfenster

Die Listen

Vorlagen und Briefe/Emails

Netzwerk-Modus

Das Internet Anmeldeformular

Sicherheitsstufen

Felddefinitionen

spezielle Felder

Upgrade von Version 1 auf Version 2


Wie kann ich ... ?

Warum ... ?






Was? Woher? Wieviel? Was gibt's zum Abendessen?

Larson2 ist ein kleines Proggi, um Dir die Planung eines Cons zu erleichtern. (wenn Du nicht weisst, was ein Con ist, dürfte es für Dich...von minderem Interresse sein)
Es verwaltet Teilnehmerdatensätze mit Personendaten, Spielerdaten/fähigkeiten, Bildern, Bank- und Anreisedaten, Charaktergeschichten, benutzerdefinierte Felder und was weiss ich alles, Orga- und Helferaufgaben, Teilnehmergruppen, NSC-Rollen, Aufteilung der Zimmer/Zelte, druckt und verschickt per Email Serienbriefe, druckt Listen, hat ausgedehnte Such- und Listenfunktionen, kümmert sich um die Preisstaffelungen, ist netzwerkfähig für einen flotten Check-In, merkt sich Datensätze für den nächsten Con, kocht Erbsensuppe und stopft Socken.
Neu in Version 1.3.01.17: Es gibt ein Html-Formular, womit sich die Leute im Internet zum Con anmelden können. Die Daten werden dann per Email verschickt, die Larson2 selbst holen und verarbeiten kann. Dadurch entfällt die ganze von-der-Anmeldung-in-den-Compi-hack-Arbeit

Kosten tut's nix :-)
Ich hab' Larson2 aus Spass programmiert. Allerdings stecken einige hundert Arbeitsstunden drin und es kann Dir so manche ersparen.
Deshalb schlage ich denen, die sich erkenntlich zeigen wollen, folgenden Deal vor:
Wenn Du einen Con veranstaltest und verwendest dabei Larson2, darf ich zum halben Preis kommen. Also kein Bescheidsagen oder Bevorzugung oder so'n Quatsch... einfach nur wenn, dann billiger. Schliesslich bin ich dann auch anwesend und kann Support leisten, wenn's brennt. Aber wie gesagt, das ist keinesfalls obligatorisch!!! Tu' mit Larson2, was Du willst :-)

Larson2 ist mit Delphi 5 geschrieben. Den Quellcode geb' ich gerne weiter, einfach melden.

Der Autor:
Julian Bischof, larson2 ätt fractsurf punkt de
Kriegen tust Du Larson2 auf meiner Homepage:
http://www.fractsurf.de
bzw. auf der Homepage von Larson2:
http://www.fractsurf.de/larson2


Nach oben

Larson2 einrichten

Also erstmal muss man Larson2 ja einsatzbereit kriegen. Unbedingt nötig sind dazu folgende Dateien: Um die Makros nutzen zu können, muss MS Word und Excel (ich glaube ab Version '97) installiert sein. Wenn Du kein Office hast, läuft Larson2 natürlich auch, ein Grossteil des Nutzens geht aber verloren.
Optional sind folgende Dateien: Alle Dateien müssen im selben Ordner liegen (ausser Hilfe-Datei).
So weit, so gut. Wenn man Larson2 das erste mal startet, wird man gleich nach einem Stammverzeichnis gefragt. In diesem legt Larson2 im Betrieb dann alle möglichen Unterordner/Dateien an. Diese sind zum Teil verschlüsselt(Datenschutz...) und sollten sowieso nicht verändert werden. Das Stammverzeichnis ist sozusagen das "Hoheitsgebiet" von Larson2. Standardmässig schlägt Larson2 einen Unterordner des Ordners vor, in dem das Programm liegt. Das ist meistens OK. Natürlich muss das Verzeichnis beschreibbar sein, also insbes. keine CD. Sonst kackt Larson2 total ab.
Als nächstes frägt(fragt?) Larson2 nach einem "Datenschlüssel". Das ist ein Passwort, mit dem alle Daten verschlüsselt werden. Ausserdem ist es so eine Art Masterpasswort, mit dem man neue User anlegen kann. Normalerweise braucht man es nicht oft. Trotzdem sollte man es sich gut merken, sonst kann es theoretisch passieren, dass alle Daten futsch sind. Ausserdem kann es nachträglich nicht mehr geändert werden.
Jetzt sollte Larson2 starten. Man sieht ein ziemlich leeres Fenster und ein paar Knöpfe, von denen die meisten grau sind. Die erste Amtshandlung sollte sein, einen Admin (das bist dann Du :-) anzulegen.
Fein fein, jetzt ist Larson2 eigentlich startklar und Du kannst Dich einloggen und einen neuen Con anlegen.

Nach oben

Neuen User anlegen

Im Menü "User -> Neuer User" anklicken. Name, Passwort eingeben, evtl. Admin anhaken, um dem User Adminrechte zu verpassen - das geht nur hier und später nicht mehr. Der Username muss übrigens alphanumerisch sein, also nur Buchstaben und Zahlen enthalten.
Das Masterpasswort (das ist der Datenschlüssel, s.o.) musst Du nur eingeben, wenn Du gerade nicht als Admin eingeloggt bist oder einen neuen Admin anlegen willst.
Wenn Du ein eingeschränktes Userprofil anlegen willst, musst Du jetzt im Menü auf "User -> Userrechte ändern" klicken und die einzelnen Rechte für den User an/abhaken. Das darf man aber nur als Admin.


Nach oben

Neuen Con anlegen

Im Menü "Datei -> Neuer Con" anklicken. Dazu musst Du natürlich eingeloggt sein, und zwar mit den entsprechenden Rechten.
Als erstes musst Du Dir einen Namen ausdenken. Larson2 legt dann einen gleichnamigen Unterodner in seinem Stammverzeichnis an; der Name muss also entsprechend gewählt werden. Wenn der Name gültig ist, wird der Con angelegt und gleich geöffnet.
Wenn Du das Recht "Con-Fenster" hast, kannst Du ein kleineres Fensterchen sehen, in dem allerhand Optionen für den Con möglich sind. Du solltest unbedingt gleich Con-Start und -Ende eingeben. Sonst meckert Larson2 ständig rum, er könne keine Spielerpreise berechnen.
Ausserdem kann man die idealen und maximalen Spielerzahlen eingeben. Ist eine der Zahlen überschritten, wird das Feld, in dem diese Zahl steht, gelb bzw. rot. Man kann diese Zahlen aber trotzdem überschreiten; es soll nur ein Hilfsmittel sein. Ausserdem solltest Du auch die Preisstaffelung eintragen. Dass muss aber nicht unbedingt gleich sein und man kann das auch später noch ändern (siehe Geldsystem).


Nach oben

Rechte in Larson2

In Larson2 gibt es Userprofile mit diversen Rechten. Der Sinn dahinter ist, dass man sich z.B. Helfer für den Check-In oder den Briefverkehr holen kann, ohne dass diese an "sensibleren" Sachen wie der Preisstaffel oder den Email-Accounts rumpfuschenn können. Praktisch oder??
Das ganze funzt dann etwa so: Es gibt "Edititerrechte", Lese- und Schreibrechte. Die Lese- und Schreibrechte beziehen sich auf die einzelnen Felder der Teilnehmerdatensätze. Diese hängen zum Teil voneinander ab. So muss z.B. jemand, der Datensätze anlegen darf (das ist ein Editierrecht), auch Schreibrechte auf alle Felder der Datensätze haben - logisch oder? Wenn Du ein eingeschränktes Profil anlegen willst, solltest Du unbedingt testen, ob alles klappt, was das Profil dürfen soll.

Ein Helfer für den Briefverkehr z.B. braucht auf jeden Fall die Editierrechte Con öffnen/schliessen und Briefe drucken/verschicken. Soll er auch Anmelde- und Teilnahmebestätigungen verschicken, braucht er ausserdem das Editierrecht Con speichern und Schreibrechte auf den Status der Anmelde- und Teilnahmebestätigung der einzelnen Datensätze, da Larson2 sich den Status diesbzgl. merken will (bzw. es einem abnimmt, sich zu merken, wer schon was auf welchem Weg erhalten hat).


Alle Editierrechte:
Recht Beschreibung
Adminrechte Wer Adminrechte hat, darf alles. Dieses Recht kann nur beim Anlegen eines Profils geändert werden
Con speichern Den Con mitsamt allen Daten speichern. Wer Schreibrechte hat, sollte dieses Recht auch haben, da ja sonst die Änderungen verloren gehen.
Con schliessen/oeffnen Wer dieses Recht nicht hat, darf einen Con insbes. nicht schliessen. So kann man z.B. verhindern, dass jemand den Con schliesst, ohne vorher zu speichern. Umgekehrt kann man jemand daran arbeiten lassen und später selbst speichern, nachdem man die Änderungen überprüft hat.
Con anlegen/loeschen Neuen Con anlegen bzw. einen bestehenden löschen.
Con-Fenster Im Con-Fenster stehen alle "sensiblen" Daten bzgl. des Cons: Start-Datum, Preisstaffel, max. Anzahl Teilnehmer usw.
Orga-Aufgaben-Liste Liste mit Orgaaufgaben.
Helfer-Aufgaben-Liste Liste mit Helferaufgaben
Klassen-Liste Liste aller Spielerklassen
Rassen-Liste Liste aller Spielerrassen
Systeme-Liste Liste aller Spiel-Systeme
Faehigkeiten-Liste Liste aller Spieler-Fähigkeiten
Gruppen-Liste Liste aller Spielergruppen mit Beschreibung
Vorlagen-Liste Liste aller Brief/Email-Vorlagen
NSC-Rollen-Liste Liste aller NSC-Festrollen
Datensaetze anlegen/bearbeiten Legt fest, ob ein User in die Eingabe-Maske für Teilnehmer-Datensätze darf. Wer dieses Recht hat, hat auch alle Schreib- und Leserechte
Datensaetze loeschen Legt fest, ob Teilnehmer-Datensätze gelöscht werden dürfen
Briefe drucken/verschicken Legt fest, ob jemand Briefe/Emails drucken & versenden darf.
Email-Optionen Legt fest, ob man die Email-Optionen ändern darf. Diese beinhalten die komplette Adresse der Orga und Daten zum Email-Account, über den Emails automatisch versendet werden.
Anmeldemails abrufen/bearbeiten Legt fest, ob man die Anmelde-Emails abrufen und verarbeiten darf.

Nach oben

Das Geldsystem

Festlegen der Preisstaffel / Preismods
Im Con-Fenster im Register Preise kann man für die vier Teilnehmertypen SC, NSC, Helfer und Orgamitglied jeweils Grundpreis und Kaution angeben. Ausserdem gibt's eine Rabatt- bzw. Aufschlags-staffelung nach Alter und nach dem Datum, an dem bezahlt wird.
Im Register PreisMods gibt's Preismodifikatoren; das sind ein Rabatt für Sanis bzw. Aufschlag für Conzahler und vier selbst definierbare Preismods. Bei letzteren kann man einen Namen und einen Betrag angeben. Ausserdem gibt's für jeden PreisMod ein Häkchen "Fixpreis"; ist es angehakt, gilt exakt dieser Preis und alle anderen Rabatte / Aufschläge werden ignoriert (Natürlich kann nur höchstens ein Fixpreis angehakt werden).
Ein kleines Beispiel steht hier

Preisberechnung
Larson2 verwaltet dann selbständig das Soll- und Istkonto für Beitrag und Kaution aller Teilnehmer. Um eine Zahlung zu vermerken, gibt es in der Eingabemaske und im Suchfenster einen Knopf "Ein/Auszahlung". Dort kann man angeben, wann die Zahlung erfolgt ist, woraufhin Larson2 errechnet, was der Teilnehmer (noch) zu zahlen hat. Dort kann man auch die Bankverbindung für evtle Rückerstattungen eintragen. Larson2 führt eine Liste aller Ein/Auzahlungen (die kann man sich über das Con-Fenster ansehen) und merkt sich zusätzlich in jedem Datensatz den aktuellen Kontostand.
Wie gesagt gibt es auch einen Conzahler-Aufschlag für Leute, die erst bei der Anreise bezahlen (schliesslich hat man dann blöderweise einen Haufen Bargeld rumfliegen). Damit Larson2 diesen bei der Preisberechnung berücksichtigt, musst Du im Menü unter "Einstellungen -> Optionen" den Punkt "Check-In" anhaken. Dadurch weiss Larson2, dass gerade Check-In gemacht wird, also insbesondere jeder, der jetzt noch bezahlt, ein Conzahler ist (Achtung: diese Einstellung ist im Netzwerkbetrieb nicht änderbar, also erst den Haken setzen und dann den Server aufmachen).
Die Preisstaffelung im Con-Fenster kann man übrigens jederzeit ändern. Beim Öffnen eines Cons und beim Zugriff auf einzelne Datensätze werden immer die Felder ZuZahlen, KautionZuZahlen und die Statusflaggen Bezahlt und GeldErledigt aktualisiert (was die bedeuten siehe spezielle Felder).


Nach oben

Neuen Datensatz anlegen

Wenn ein Con geöffnet ist und Du die entsprech. Rechte hast, kannst Du neue Teilnehmerdatensätze anlegen. Dazu im Menü "Bearbeiten -> Neuer Teilnehmer" klicken (Shortcut Strg+N).
Die erste Eingabemaske öffnet sich. Darin stehen alle Personen-, Anreise-, Status- und Kontodaten. Ausserdem kann man Allergien, Lebensmittelallergien, Phobien usw. eintragen - man weiss nie wofür's gut ist... Als letztes wählt man den Spielertyp - SC, NSC, Helfer oder Orgamitlglied.
Klickt man auf weiter, kommt man dann je nach Spielertyp zu den "Spezialdaten". Bei SCs kann man dann Charaktername, Fähigkeiten, Klasse, Rasse, Beruf usw. eintragen. Ausserdem gibt's ein Häkchen, ob die SL mit dem Charakter einverstanden ist. Das ist praktisch, wenn man später z.B. eine Liste aller "problematischen" Charaktere haben will (siehe Suchfenster). Bei NSCs gibt's ein Feld für Erfahrungspunkte, ob er kämpfen kann, ob und welche Festrolle er spielt (siehe Listen) usw. Bei Helfern und Orgaleuten kann man ihre/seine Aufgaben, Führerscheinklasse und ob ein KFZ vorhanden ist, eintragen. Bei allen Typen kann man ein Bild einfügen (per Twainsource(Scanner/Digicam) oder aus Datei).
ab [2.4.6.29]: Klickst Du hier auf weiter, kommst Du zur letzten Eingabemaske für benutzerdefinierte Felder; falls welche angelegt sind. Hier sind alle von Dir definierten Felder aufgeführt.

Es gibt in der ersten Maske auch einen Knopf "Suchen". Wenn Vor-, Nachname und Geburtsdatum eingtragen sind und man auf Suchen klickt, sucht Larson2 in allen alten Cons danach. Man muss also Stammkunden nur einmal eintragen.


Nach oben

Zugriff auf Datensätze: Das Suchfenster

Das Suchfenster ist das "Haupttool" in Larson2. Von hier aus kann man eigentlich alles machen: Neue Datensätze anlegen, alte ansehen, einzelne Werte bearbeiten, Serienbriefe usw.

Um nach der Eingabe wieder an die Datensätze zu kommen, muss man ein neues Suchfenster öffnen (Menü "Bearbeiten -> Neue Suche", Shortcut Strg+F). Im linken Teil des Fensters kann man die Datenmenge filtern, wählen, welche Datenfelder angezeigt werden und verschiedene Sachen mit dem ausgewählten Datensatz bzw. der ganzen Liste anstellen. Im rechten Teil sieht man die (Treffer-)Liste.
Zum Filtern sieht man vier "Blöcke", in die man Bedingungen eintragen kann und die per und/oder verknüpft werden. Das klingt komisch, ist aber eigentlich ganz einfach (und sehr mächtig...):
Ein Block besteht aus drei Feldern (und einem Häkchen, dass man natürlich anhaken muss, damit die Bedingung verwendet wird): Ein Feld, in das man den Namen des Datenfeldes, das verglichen wird, einträgt (Das ist eine Dropdown-Liste, Du musst Dir also keine Sorgen um die Feldnamen machen), ein Feld für den Vergleichsoperator("=", "<>", "enthält" usw., auch Dropdown-Liste) und ein Feld für die Vergleichsreferenz. Will man etwa rausfinden, wer noch nicht bezahlt hat, trägt man sinngemäss "Bezahlt" "=" "false" ein. Oder sucht man alle SCs, schreibt man "Spielertyp" "=" "SC". Noch ein Beispiel: Will man rausfinden, wer überhaupt schon irgend etwas bezahlt hat, benutzt man zwei Blöcke: einmal "KontoStand" "<>" "0", per "oder" verknüpft mit dem nächsten Block "KautionsKonto" "<>" "0".
Will man mit dem Inhalt eines anderen Datenfeldes vergleichen, muss man dessen Namen in eckige Klammern("[]") schreiben. So ergibt etwa "Kontostand" "<>" "[ZuZahlen]" alle Datensätze, in nicht oder einen falschen Betrag bezahlt haben.
Standardmässig, also wenn Du einfach auf Return drückst, werden nur echte Teilnehmer gesucht (s. spezielle Felder). Es gibt aber einen zweiten Knopf "Suchen (alle)". Benutzt Du diesen, werden auch Datensätze aufgelistet, die auf der Warteliste stehen, abgemeldet oder nicht angemeldet sind, also am Con nicht teilnehmen.

Eine Besonderheit bei den Datenfeldern stellt der "Status" dar. Er umfasst mehrere (Ja/Nein-)Flaggen, die eben über den Zustand des Teilnehmers auskunft geben. Dazu gehören Angemeldet, Bezahlt, Warteliste, Nimmt_Teil, GeschaeftsBed ,GeldErledigt, Eingecheckt, Ausgecheckt, Abgemeldet. Manche dieser Flaggen sind schreibgeschützt, bzw. werden bei nächster Gelegenheit von Larson2 wieder korrigiert(GeldErledigt und Bezahlt). Will man wissen, ob einer dieser Zustände zutrifft, fragt(frägt?) man wie in den Beispielen erwähnt "Status" "enthält" [Flagge][2.4.6.29:Status entfernt, s. spezielle Felder]

Extrem nützlich ist das ganze für Serienbriefe wie z.B. die Anmelde- bzw. Teilnahmebestätigungen. So kann man als Kriterium einfach "Anmeldbestät.Status" "=" "unbearbeitet" eintragen und dieser Liste einen Serienbrief schicken (im Vorlagendialog dann angeben, dass es sich um eine Anmeldebestätigung handelt).
Man kann Suchmuster auch speichern/laden.

Die Auswahl der Ansicht ist denkbar einfach: Für jedes Datenfeld gibt's ein Häkchen. Ansichten kann man auch speichern/laden.

Jetzt zur Bearbeiten-Leiste. Es gibt eine Box für den ausgewählten Datensatz und eine für die ganze Liste, die gerade angezeigt ist:
Ausgewählter Datensatz Funktion
Bearbeiten Öffnet die Eingabemaske für den ausgewählten Datensatz. Doppelklick auf die ID in der entsprech. Zeile der Liste hat dieselbe Funktion.
Löschen Löscht den ausgewählten Datensatz (also der ist dann echt weg, nicht nur aus der Liste entfernt...)
Brief Öffnet den Auswahldialog für Vorlagen, um dem ausgewählten Datensatz einen Brief zu drucken/mailen
Ein / Auszahlung Öffnet den Ein / Auszahlungsdialog.
Feldwert ändern Öffnet ein kleines Fensterchen, um einen bestimmten Feldwert des ausgewählten Datensatzes zu ändern. Das ist für eingeschränkte Userprofile gedacht: Wenn ein User nicht das Edittierrecht "Datensätze bearbeiten", sondern nur einzelne Schreibrechte hat, darf er nicht in die Eingabemaske. Auf diesem Wege kann er dann trotzdem einzelne Felder bearbeiten.
Gesamte Liste Funktion
Drucken Druckt die gerade angezeigte Liste wie sie ist über Excel aus (zum Aussehen der Liste s.u.).
Druckansicht Schickt die Liste wie sie ist an Excel, druckt sie aber nicht gleich aus, sondern zeigt das erzeugte Excel-Sheet an.
Serienbrief Öffnet den Auswahldialog für Vorlagen, um einen Serienbrief an alle Datensätze in der Liste zu drucken/mailen
Feldwert ändern Wie bei Ausgewählter Datensatz, Änderung wird aber auf alle Datensätze, die gerade angezeigt werden, angewandt.

[2.4.6.29] Der Doppelklick auf eine Zeile der Liste hat sich etwas verändert: Doppelklickt man auf die ID, öffnet sich wie bisher die Eingabemaske. Doppelklickt man auf einen anderen Wert, öffnet sich ein kleines Fensterlein, um diesen Feldwert zu ändern; sofern er beschreibbar ist.

Man kann das Aussehen der Liste im Menü unter "Einstellungen -> Optionen" und dort unter Allgemein mit dem Knopf "Listenfarben" ändern. Dort kann man jede Menge Bedingungen (genau in dem Stil der Filterblöcke) und die entsprechende Farbgebung angeben. Standardmässig werden Helfer und Orgaleute in grauem, Leute, die noch nicht bezahlt haben in rotem Text, der ausgewählte Datensatz blau und blockierte Datensätze rot hinterlegt angezeigt.


Nach oben

Die Listen

Unter "Einstellungen -> Listen" hat man verschiedene Listen. Es gibt zwei Arten: Einfache Textlisten (Dazu zählen Orga- und Helferaufgaben , Klassen, Rassen, Berufe, Systeme, Fähigkeiten, Blacklist und Zimmer/Zelte) und Listen mit grösseren, benannten Texten (Spielergruppen und NSC-Festrollen).
Bei den einfachen Listen läuft das meistens so: Alle Eingaben werden gespeichert. Wenn man etwa bei der Eingabe eines SCs seine Fähigkeiten einträgt, werden diese in der Liste gespeichert, sodass man sie bei der Eingabe des nächsten Datensatzes bloss noch auswählen muss. Über den Menüpunkt kann man z.B. falsche Eingaben löschen oder Voreinstellungen machen.
In die Blacklist kann man Arschlöcher eintragen. Wenn man dann ein solches in der Eingabemaske einträgt, wird man gewarnt.
Die anderen Listen repräsentieren Sammlungen von grösseren Texten. Wenn Du Dir z.B. ein paar Festrollen für NSCs ausgedacht und jeweils eine Beschreibung geschrieben hast, kannst Du Ihnen in der Liste NSC-Festrollen jeweils einen Namen geben und unter diesem Namen die Beschreibung speichern. In der Eingabemaske für NSCs kannst Du dann unter diesen Festrollen wählen und Dir jederzeit die Beschreibung anzeigen lassen.

Alle Listen gelten global für alle Cons. Wenn Du also mehrere Cons veranstaltest, ersparst Du Dir einen Haufen Schreibarbeit...


Nach oben

Vorlagen und Briefe/Emails

Vorlagen dienen zum schreiben von (Serien-)Briefen und Emails.
Unter dem Menüpunkt "Einstellungen -> Vorlagen" kann man sie anlegen. Um eine neue Vorlage anzulegen, klickst Du im Vorlagen-Dialog auf "Neu" (bzw. wenn Du ein existierendes Word-Doc übernehmen willst auf "importieren"). In beiden Fällen musst Du erstmal einen Namen eintragen. Anschliessend öffnet sich die Vorlage in Word und man sieht eine Commandbar namens "Larson2 Platzhalter einfügen".
Jetzt kannst Du das Dokument beliebig gestalten. Wenn Du die Platzhalter benutzt, werden sie beim Erzeugen eines Briefes durch den jeweiligen Inhalt des Datensatzes ersetzt. Es gibt auch einen Platzhalter für das Bild (Larson2 speichert alle Bilder im Format Breite : Höhe = 4 : 3. Darauf solltest Du beim Verwenden des Platzhalters für das Bild achten).

Um einen (Serien-)Brief zu schreiben, musst Du im Suchfenster auf Brief bzw. Serienbrief klicken. Ein Dialog öffnet sich, wo Du die Vorlage, die Du verwenden möchtest, auswählen kannst. Hier hast Du drei Möglichkeiten, wie der/die Brief(e) versendet werden:
Wie im Datensatz angegeben: In der Eingabemaske gibt's ein Feld Briefverkehr mit den Optionen "per Email", "per Post" oder "beides". Der erzeugte Brief wird dann je nach Inhalt dieses Feldes gedruckt, per Email versendet oder eben beides. Verwendest Du diese Option, kannst Du angeben, ob bzw. in welchem Feld Larson2 sich merken soll, dass ein Brief versendet wurde (Beispiel unten).
anders: Hier kannst Du angeben, ob der/die Brief(e) gedruckt und/oder per Email versendet werden sollen.
nur speichern: Ab Version 2.4.6.29 kann sich Larson2 zu jedem Datensatz auch beliebig viele Dateien merken (siehe Datenfelder). Bei dieser Option wird/werden Brief(e) erzeugt, aber nicht versendet oder gedruckt, sondern nur gespeichert (Beispiel unten).

Unabhängig von der gewählten Option kannst Du den/die erzeugten Brief(e) in einem Feld vom Typ Datei speichern (siehe Datenfelder).

Schliesslich gibt es noch die "Direkteingaben". Dafür kann man auch Plathhalter in den Vorlagen einfügen und jeweils beim Erzeugen den Inhalt direkt angeben. Das kann man für Notizen oder Bemerkungen verwenden.

Nicht verwendete Platzhalter werden übrigens gelöscht -also kann man ruhig grosszügig etwa mit den Direkteingaben umgehen.

Beispiel: AGBs beim Check-In unterschreiben: Du willst ja sicher, dass alle Teilnehmer die AGBs unterschreiben. Wenn es Dir genügt, dass dies beim Check-In geschieht, kannst Du das recht geschmeidig lösen: Leg' ein Feld "AGB" o.ä. vom Typ Datei und eins etwa "AGB_unterschrieben" vom Typ Ja/Nein an. Kurz vor dem Con machst Du einen Serienbrief mit den AGBs als Vorlage an ALLE TEILNEHMER, und verwendest als Option "nur speichern" im Feld AGB. Beim Check-In kannst Du dann die Datei direkt ausdrucken (zum Zugriff auf die Datei kannst Du Dir z.B. in der Liste des Suchfensters das Feld ABG anzeigen lassen; dann brauchst Du nur drauf Doppelklicken), unterschreiben lassen und dies im Feld AGB_unterschrieben vermerken. Krass oda?!

Emails enthalten übrigens nur eine kurze Nachricht in der Art "Dies ist eine Nachricht des Cons blablabla..." und im Anhang befindet sich das erzeugte Dokument. Wenn Emails erzeugt werden, werden sie zunächst einfach nur gespeichert. Um sie zu verschicken, musst Du im Menü auf "Bearbeiten -> Emails" klicken (Shortcut Strg+E). Es öffnet sich ein Fenster mit einer Liste aller Emails, die erzeugt und noch nicht verschickt wurden. Man kann sie ansehen und löschen, wenn man Mist gebaut hat. Klickt man auf "Alle senden", werden sie verschickt - natürlich muss dann eine Internetverbindung bestehen. Dazu muss man vorher im Menü unter "Einstellungen -> Optionen" und dort unter "Email-Optionen (Versenden)" die Account-Daten eintragen.Z.B. GMX verlangt vor dem Verschicken per SMTP eine Anmeldung per Pop3; deshalb kann man auch die Pop3-Daten angeben. Larson2 holt keine Mails, sondern meldet sich bloss an, um anschliessend versenden zu dürfen.[2.4.6.29]: Larson2 setzt ab sofort voraus, dass das Versenden über gesichteres SMTP erfolgt.

Wenn Du Emails im Klientenmodus schreibst, sind ein paar Dinge zu beachten: Gespeicherte Emails sind das einzige, was sich Klienten merken. Wenn Du Dich beim Server einloggst, werden die Orgaadressse und die Email-Accountdaten übertragen. Beim Erzeugen von Emails wird die Orgaadresse mit ihnen gespeichert. Wenn Du sie jetzt verschickst, ist alles soweit OK. Wechselst Du aber in einen lokalen Modus, werden zwar die Emails erhalten, nicht aber die Accountdaten (sonst würden ja Deine eigenen Daten überschrieben). Wenn Du jetzt die Emails verschickst, wird Dein eigener Account benutzt, in der Email steht aber (in den Feldern FromAddress und ReplyTo) die Adresse, die Du vom Server erhalten hast. Das kann bei manchen Providern dazu führen, dass der Server sich weigert, die Email zu verschicken, da der Absender nicht mit der Emailadresse des verwendeten Accounts übereinstimmt. Das kann man vermeiden, indem man entweder die Emails verschickt, während man noch beim Server eingeloggt ist, oder die selben Accountdaten einträgt, die der Server hat.


Nach oben

Netzwerk-Modus

Damit mehrere Leute gleichzeitig an Larson2 rummachen können (z.B. mehrere CheckIn-Stationen), ist Larson2 netzwerkfähig. Konkret, oder??
Im Netzwerk gibt es einen Server und beliebig viele Klienten. Auf dem Computer, wo der zu bearbeitende Con liegt, muss ein Admin angemeldet und der Con geöffnet sein. Die anderen können sich dann dazuklinken. Auf den Klienten sollten unbenutzte Larson2-Installationen sein, da dort so ziemlich alles überschrieben wird. Zur Not einfach die Programmdateien in einen neuen Ordner kopieren und dort ausführen.[1.3.1.27] Wenn die Computer im selben C-Netz sind (das heisst, die ersten drei Zahlen der IP-Adresse sind gleich), finden die Klienten den Server automatisch - sofern er offen ist.
Um einen Server zu öffnen, im Menü auf "Einstellungen -> Netzwerk -> Netzwerkserver" klicken, wenn Du magst noch ein Passwort angeben, das jeder vor dem Zugriff auf die Daten angeben muss - fertig. Ein Chatfenster und eins, in dem die Klienten aufgeführt werden, öffnet sich. Damit keine Konflikte auftreten, sind dann am Server verschiedene Einstellungen nicht mehr möglich. Z.B. wird das Con-Fenster geschlossen oder der Haken "Check-In" in den Optionen ist deaktiviert (siehe Geldsystem). [Neu seit 1.3.1.27]: Indem Du auf ein LED im Klientenfenster klickst, kannst Du Klienten rausschmeissen (Es wird auch gefragt, ob diese IP für den Rest der Sitzung ignoriert werden soll)
Um sich als Klient einzuklinken, im Menü auf "Einstellungen -> Netzwerk -> Netzwerklient" klicken. Auch hier öffnet sich das Chatfenster. Wenn die Rechner wie gesagt im selben C-Netz sind, einfach ein zwei Sekunden warten. Ansonsten in das jetzt geöffnete Chatfenster entweder die IP oder den Namen des Servers (im lokalen Netzwerk geht auch der Name, der in der Netzwerkumgebung erscheint) eintragen und auf Verbinden klicken.
Wenn ein Server gefunden wurde wird seine IP angezeigt und gefragt, ob Du Dich verbinden willst. [Neu seit 1.3.1.27]:Wenn der Server passwortgeschützt ist, wirst Du jetzt aufgefordert, es einzugeben. Weisst Du es nicht, darfst Du trotzdem chatten (Um Dich z.B. nach dem Passwort zu erkundigen). An die Daten darfst Du allerdings erst, wenn Du es eingegeben hast (Du wirst danach gefragt, sobald Du auf Einloggen klickst).

Als nächstes wird gefragt, ob Du die "Presets" laden möchtest.[1.3.1.27] Das sind die ganzen Listen und sonst. Einstellungen (gespeicherte Suchmuster, Vorlagen usw.). Beim erstmaligen Verbinden mit dem Server solltest Du das unbedingt tun. Eigene Einstellungen werden aber logischerwiese überschrieben. Wenn Du also 47tausend tolle Suchmuster gespeichert hast und Dich wg. Serverabsturz neu einklinkst, würde ich die Presets nicht laden.[1.3.1.27 Da auf dem Klient alles nur noch temporär ist, werden die Presets bei jedem Einloggen geladen]

Larson2 holt als nächstes die Userdatei vom Server und überträgt damit alle Userprofile. Wieder wird die lokale Userdatei überschrieben. Das ist übrigens der Hauptgrund, warum eine frische Larson2-Installation benutzt werden sollte: Anhand der Userdatei überprüft Larson2 die Passwörter und den Datenschlüssel. Wenn also lokale Cons auf dem Klient liegen, sind sie für Larson2 nicht mehr lesbar, weil er glaubt, der Datenschlüssel sei falsch.[1.3.1.27]
Du musst Dich jetzt mit einem der Profile vom Server einloggen. Wenn das geschehen ist, holt Larson2 die Con-Daten vom Server. Es ist nicht mehr möglich, einen Con zu schliessen, öffnen oder speichern: Alle Änderungen gehen an den Server und werden dort gespeichert.
Ansonsten funzt jetzt Larson2 ziemlich normal - bis auf ein paar Einschränkungen. Z.B. kann man neue Datensätze nur auf dem Server anlegen.[1.3.1.27] Der Datenfluss vom Klient zum Server beinhaltet nur die Datensätze und Bilder. Sonstige Änderungen (Listen, Charaktergeschichten, Suchmuster ...) werden nicht übernommen (Da hätt' ich mich totprogrammiert: Verarbeite mal zwei gleichzeitige Änderungen an derselben Liste...).

Um den Netzwerk-Modus zu verlassen, im Menü auf "Einstellungen -> Netzwerk -> Kein Netzwerk" klicken. Das Chatfenster wird geschlossen und im Klienten-Fall der Con geschlossen(Klar, der liegt ja auf dem Server) und der User ausgeloggt.

Das Netzwerk funzt mit jeder IP-Verbindung, also auch über das Internet. Das ist aber nicht ratsam, da alle Daten im Klartext übertragen werden - ich würde mich bedanken, wenn ein Veranstalter meine kompletten Personendaten mit Email-Adresse, Bankverbindung und Bild in die Welt schickt. Ausserdem ist die Datenmenge ziemlich beachtlich und höchstens mit DSL realistisch.[1.3.1.27 Daten werden verschlüsselt und komprimiert]


Nach oben

Das Internet Anmeldeformular

Es gibt auch ein Html-Formular, das Du einrichten kannst, damit die Leute sich per Internet selbst anmelden können.
Um es zu benutzen, musst Du ein paar Dinge beachten:

Zunächst einmal ist zu sagen, dass es ohne cgi, php o.ä auskommt, also auf jedem Webspace verwendet werden kann. Die Anmeldung läuft dann so ab, dass der User durch drei Seiten geführt wird, und am Ende eine Textbox präsentiert kriegt, dessen Inhalt er an eine (von Dir) angegebene Email-Adresse schicken soll. Das geht dann entweder per Button, oder, wenn sein Browser das nicht kann, von Hand per Copy&Paste.

Erzeugen eines Formulars: ab [2.4.6.29]
Da in Larson2 benutzerdefinierte Felder eingeführt wurden, kann man jetzt das Anmeldeformular dynamisch erzeugen.
Dazu solltest Du zuerst sorgfältig die Datenfelder abklappern und die Häkchen "intern" und "Pflichtangabe" nach Deinen Wünschen setzen. Die Seitenangabe bei Datengruppen wirkt sich übrigens nicht aus, sondern ist für das geplante php-Formular gedacht.
Ausserdem musst Du im Menü unter "Einstellungen -> Optionen" und dort unter "Email-Optionen (Empfangen)" die Daten der Mailbox angeben, an die die Anmeldungen geschickt werden und von wo sich Larson2 diese dann holt.
Wenn Du jetzt auf "Ex/Import -> Html-Anmeldungen -> Formular erzeugen" klickst, legt Larson2 ein entsprechendes Formular an, das Du einfach ins Netz stellen kannst (Natürlich kannst/solltest Du noch einen einleitenden Text usw. einfügen; im Prinzip kommt man aber ohne Html-Kenntnisse aus).
Es ist ratsam, erst das Formular ins Netz zu stellen, wenn keine Änderungen an den Datenfeldern mehr zu erwarten sind, da sonst evtl. Werte verloren gehen.

Abrufen und Verarbeiten der Anmeldungen
Um die Anmeldungen abzurufen, brauchst Du bloss noch auf "Ex/Import -> Html-Anmeldungen -> Emails -> Emails abrufen/löschen" zu klicken und das Passwort einzugeben. Larson2 ruft dann alles ab und beginnt mit der Verarbeitung.
Wenn Du in den Optionen "Emails vom Server löschen" auf "nach erfolgreichem Import" stellst, löscht Larson2 - tataaa - jede Email vom Server, die eine Anmeldemail ist und in einen Datensatz importiert wurde. Das macht er allerdings erst beim nächsten Verbinden, da er erst alles abruft und später verarbeitet.
Stösst Larson2 auf unlesbare Werte (z.B. eine komische Datumsangabe), wirst Du gefragt, ob Du das entziffern kannst und kannst ggf. den Wert eintragen.

Übrigens wird bei jedem importierten Datensatz "Angemeldet" auf false gesetzt. Dadurch gelten diese erstmal noch nicht als Teilnehmer (s. spezielle Felder). Es gibt ein Suchmuster und eine Ansicht "Neue Anmeldungen", womit man die Neuen dann ganz einfach auflisten, durchsehen und endgültig anmelden kann.


Nach oben

Sicherheitsstufen

[ab V 2.4.6.29]

Du solltest Dir darüber im Klaren sein, dass Du eine gewisse Verantwortung damit übernommen hast, so viele und umfangreiche Datensätze elektronisch zu speichern.

In Larson2 sind alle Daten mit einem Datenschlüssel verschlüsselt gespeichert (s.o.). D.h., bevor man an die Daten ran kann, muss Larson2 dieser Schlüssel bekannt sein.
Damit man ihn aber nicht bei jedem Programmstart eingeben muss, speichert ihn Larson2 - je nach Sicherheitsstufe - mit dem Passwort einiger User verschlüsselt. D.h., wenn sich bei Programmstart ein User, mit dessen Passwort der Datenschlüssel gespeichert wurde, einloggt, entschlüsselt Larson2 damit den Datenschlüssel und kann somit auch an die Daten ran. Larson2 merkt sich den Datenschlüssel dann für den Rest der Sitzung.
Versucht sich dagegen bei Programmstart ein User einzuloggen, mit dem der Datenschlüssel nicht gespeichert wurde, können die Daten nicht gelesen werden, weil der Schlüssel fehlt.
Der Sinn dahinter ist nicht, zu regeln, wer Larson2 starten darf, sondern dass der Datenschlüssel nicht mit zu vielen bzw. schlechten Passwörten verschlüsselt vorliegt, also letztlich die Sicherheit der Dateien selbst. Womöglich ist das alles etwas übertrieben, aber ich bin wie gesagt der Meinung, dass man durchaus sensible Daten in Händen hält. Ausserdem hatte ich Bock, sowas mal zu proggeln ;-D

Folgende Sicherheitsstufen können gewählt werden (wobei ich eigentlich keinen Grund sehe, nicht bei 'normal' zu bleiben):
Stufe Beschreibung
Niedrig Der Datenschlüssel wird mit allen Userpasswörtern gespeichert, d.h., jeder kann sich bei Programmstart einloggen
Normal Der Datenschlüssel wird den Passwörtern aller Admins und aller, die das Recht "Con öffnen/schliessen" besitzen, gespeichert. Also können diese Leute Larson2 auch starten. Das halte ich für am sinnvollsten, denn wer einen Con öffnen darf, sollte das Programm auch starten können :-) Ausserdem sind Leute mit diesem Recht i.A. "vertrauenswürdig".
Hoch Der Datenschlüssel wird nur mit den Passwörtern der Admins gespeichert, also kann nur ein Admin Larson2 zum Laufen bringen.
Maximal Der Datenschlüssel wird gar nicht gespeichert und muss bei jedem Programmstart eingegeben werden. Die Datensicherheit hängt also einzig und allein von der Qualität des Datenschlüssels ab (Die Verschlüsselungsmethode ist für die nächsten 10 Jahre garantiert sicher genug :-D).


Nach oben

Felddefinitionen

Seit Version 2.4.6.29 ist es möglich, eigene Datenfelder verschiedener Typen anzulegen und ein paar Eigenschaften der Felder festzulegen. Dies geht im Confenster; aber nur als Admin :-D

Feldgruppen
Alle Datenfelder sind in Gruppen eingeteilt. Diese Gruppierung ist in der Eingabemaske für benutzerdefinierte Felder und im Anmeldeformular sichtbar. (Für jede Gruppe kann man eine "Seite" angeben, das ist z.Zt. ohne Funktion und für das geplante php-Formular gedacht.)
Klickst Du auf neue Gruppe, wird in der gerade ausgewählten Gruppe eine neue Untergruppe angelegt.

Felder anlegen/bearbeiten
Wenn eine Gruppe ausgewählt ist, kannst Du durch Klick auf neues Feld in dieser Gruppe ein - na? - neues Feld anlegen. Benutzerdefinierte Felder werden rot angezeigt und man kann deren Feldtyp ändern. Die meisten Feldtypen sind selbsterklärend; vielleicht nicht so einleuchtend sind folgende: Felder besitzen drei Eigenschaften: (Bei einigen Systemfeldern kann man übrigens einige der Häkchen nicht ändern)
Man kann die Reihenfolge und Hierarchie bzw. Gruppenzugehörigkeit der Gruppen bzw. Felder durch Kicken&Ziehen beliebig ändern. Naja fast beliebig; zwischen den fünf grossen Gruppen (Teilnehmer-, SC-, NSC-, Orga-, Helferdaten) kann man nichts verschieben.

Nach oben

spezielle Felder

Einige Felder haben in Larson2 eine besondere Bedeutung; was die Preisberechnung, die Zählweise oder ob der "Datensatz" überhaupt am Con teil nimmt betrifft. Das ist vielleicht nicht so sehr einleuchtend; deshalb hier ein Auszug der kompletten Liste der Felder.

Feldname Typ Beschreibung
SpielerTyp Spielertyp SC, NSC, Orga- oder Helfermitglied. Je nach Inhalt dieses Feldes besitzt der Datensatz eine der weiteren Datengruppen (Eben SC-, NSC-, Orga- oder Helfer-Daten).
Angemeldet Ja/Nein Der Datensatz zählt nur als Teilnehmer, wenn er auch angemeldet ist. Importierte Datensätze sind immer erstmal nicht angemeldet.
Bezahlt virtuell Bezahlt ist wahr, wenn Kontostand >= ZuZahlen und (der Teilnehmer ausgecheckt oder Kautionskonto >= KautionZuZahlen ist).
Geld_Erledigt virtuell Geld_erledigt wird falsch, wenn noch nicht alles geldmässige erledigt ist, und ist entsprechend etwas komplizierter. Damit Geld_Erledigt wahr wird, müssen folgende Punkte erfüllt sein:
  • Kontostand = ZuZahlen muss erfüllt sein.
  • Ist der Teilnehmer noch nicht ausgecheckt, muss Kautionskonto = KautionZuZahlen sein.
  • Ist er degegen ausgecheckt, muss ENTWEDER Kaution_Einbehalten wahr und KautionsKonto = KautionZuZahlen sein, ODER Kaution_Einbehalten falsch und KautionsKonto = 0 sein (d.h. entweder hat er seine Kaution zurückgekriegt oder sie wurde einbehalten).
Nimmt_Teil virtuell Jemand, der auch tatsächlich am Con teilnimmt, muss angemeldet und darf nicht abgemeldet sein oder auf der Warteliste stehen. Wenn Du im Suchfenster auf "Suchen (Teilnehmer)" klickst, werden nur die angezeigt, bei denen Nimmt_Teil wahr ist (also die Leute, die auch tatsächlich kommen)
Warteliste Ja/Nein In der Eingabemaske kann das angehakt werden, damit der Teilnehmer als auf der Warteliste stehend gilt. Eine echte Liste gibt's übrigens nicht; braucht's auch gar net: Such einfach nach WarteListe=true und sortiere nach AngemeldetAm :-)
Beim Importieren (z.B. von Internet-Anmeldungen) wird übrigens Warteliste auf wahr gesetzt, falls die maximale Zahl an Teilnehmern dieses Typs erreicht ist.
Abgemeldet Ja/Nein Abgemeldete zählen nicht als Teilnehmer.
ZuZahlen Währung wird automatisch berechnet, sofern nicht Sonderpreis wahr ist
KautionZuZahlen Währung wird automatisch berechnet.
Sonderpreis Ja/Nein Wenn angehakt, kann man ZuZahlen selbst festlegen.
PreisMod1 bis PreisMod5 Ja/Nein Umbenennbar und mit einem Preismodifikator (Geldbetrag) verbunden, wirkt sich also auf die Preisberechnung aus.

Nach oben

Upgrade von Version 1 auf Version 2

Wenn Du Larson2 Version 1.3.02.02 oder niedriger updaten möchtest, gibt's einiges zu beachten:
Nach oben

Wie kann ich ....


Nach oben

Warum....


Nach oben